Archived

This topic is now archived and is closed to further replies.

Star Wars The Old Republic

569 posts in this topic

Posted

No job but you can afford an MMO subscription, what a country!

Share this post


Link to post
Share on other sites

Posted

Endgame? On a month old game? Wow some of you have a LOT of time on your hands.

When you have chronic insomnia, you end up having a lot more time than you want.

Share this post


Link to post
Share on other sites

Posted

my lvl 30 gunslinger has been sitting in a cantina for about a week now

Share this post


Link to post
Share on other sites

Posted

my lvl 30 gunslinger has been sitting in a cantina for about a week now

Roleplaying a drunk eh?

Share this post


Link to post
Share on other sites

Posted

Anyone still enjoying this?

I tried really hard to like it. I really wanted to.

But just it didn't happen. Too many flaws.

Canceled yesterday...

Share this post


Link to post
Share on other sites

Posted

I haven't played much at all in the past couple of weeks but not because the game hasn't been fun. What flaws made you quit? I don't have quite the enthusiasm for MMOs I once had but I think it's a great game.

Share this post


Link to post
Share on other sites

Posted

Ability lag was a big one for me. I got into the game for the PVP and that was a hard one to overlook. Likewise the way the server is syncing the clients. I would target someone standing directly in front of me for an attack only to have an error pop up about range or line of site and have the player teleport away.

I wanted to like the game so much I even went out and bought a new rig

i5 2500K 3.3

Intel DZ68DB main board

8 GB Corsair 1600MHz

2 - Crucial M4 64GB SSDs (1 for OS, 1 for Games)

WD 1 TB 7200rpm

nVidia GeForce GTX560 1GB

600w OCZ power supply

And yet I still got graphics artifacts and tearing in game. Tattoine still took 2 minutes to load. I still had cut scenes where the characters would be rendered in all black except what looked to be lighting effects.

Throw in the standard complaints about ui customization, macros, addons, etc and Ive just given up.

On the flip side WoW looks and plays amazing on the new rig

Share this post


Link to post
Share on other sites

Posted

if you want mmorpg pvp try guild wars, global agenda, or dcuo

none of them have a monthly

Share this post


Link to post
Share on other sites

Posted

Ability lag was a big one for me. I got into the game for the PVP and that was a hard one to overlook. Likewise the way the server is syncing the clients. I would target someone standing directly in front of me for an attack only to have an error pop up about range or line of site and have the player teleport away.

I wanted to like the game so much I even went out and bought a new rig

i5 2500K 3.3

Intel DZ68DB main board

8 GB Corsair 1600MHz

2 - Crucial M4 64GB SSDs (1 for OS, 1 for Games)

WD 1 TB 7200rpm

nVidia GeForce GTX560 1GB

600w OCZ power supply

And yet I still got graphics artifacts and tearing in game. Tattoine still took 2 minutes to load. I still had cut scenes where the characters would be rendered in all black except what looked to be lighting effects.

Throw in the standard complaints about ui customization, macros, addons, etc and Ive just given up.

On the flip side WoW looks and plays amazing on the new rig

Ive got roughly the same setup as you and mine runs great. Quick load times and 60 fps almost everywhere. I have 16gb of ram, no ssd's, and a 250 gts card are pretty much the only differences.

As for the end game, ive been 50 for 2 weeks now. There is some, but I always wish for more. Only 6, 7 now hard modes is lame. EV and Kraggas palace raids are way too easy. It just doesnt make sense that some of the hard modes are way harder than the raids. And on top of that the ease of getting gear, pvp gear specifically, kinda takes the fun out of the work to building your gearset.

That said I have loved the game so gar, the story telling is incredible. And im hoping the new flashpoint is a sign of how awesome things to come will be. At some point I fear they are going to have to merge servers. Im on davik's estate, and past 12 am there are typically less than 80 people in the imperial fleet, which is incredibly low for a main hub at any time...

Share this post


Link to post
Share on other sites

Posted

I've gotten some of those graphical errors but it hasn't been too bad. The client/server syncing does get pretty annoying, idk if that an issue they are actively fixing. The ability delay is getting fixed in the next patch though. It's already on the test servers(edit/fix: live as of this morning) and is getting overwhelming complements on the official forums, which is normally a cesspool of negativity. That was the biggie for me, I'm ready to see how it works out.

Share this post


Link to post
Share on other sites

Posted

One thing that really bugs me....

When SWG was up, a planet was....a planet. You could get out of the spaceport, hop on your speeder, and head on out.

I decided to land on Tattooine, and 30 seconds outside Anchorhead I get this silly "exhaustion zone" message and have to go back to the marked path before I die. Lame.

Share this post


Link to post
Share on other sites

Posted

Ability lag was a big one for me. I got into the game for the PVP and that was a hard one to overlook. Likewise the way the server is syncing the clients. I would target someone standing directly in front of me for an attack only to have an error pop up about range or line of site and have the player teleport away.

I wanted to like the game so much I even went out and bought a new rig

i5 2500K 3.3

Intel DZ68DB main board

8 GB Corsair 1600MHz

2 - Crucial M4 64GB SSDs (1 for OS, 1 for Games)

WD 1 TB 7200rpm

nVidia GeForce GTX560 1GB

600w OCZ power supply

And yet I still got graphics artifacts and tearing in game. Tattoine still took 2 minutes to load. I still had cut scenes where the characters would be rendered in all black except what looked to be lighting effects.

Throw in the standard complaints about ui customization, macros, addons, etc and Ive just given up.

On the flip side WoW looks and plays amazing on the new rig

nVidia has acknowledged that this is a problem with their cards and are working on a fix for it. ATI cards are not having the same issues.

Share this post


Link to post
Share on other sites